test
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Mar 05, 2020 - 17:30 UTC
Investigating
We are currently investigating this issue.
Posted Mar 05, 2020 - 17:29 UTC