UNION Branch Lobby Closed - Appointments Available
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Nov 05, 2020 - 15:27 UTC
Investigating
The UNION branch has closed its lobby until November 5th. Appointments for in-person services are available.
Posted Oct 28, 2020 - 15:10 UTC
This incident affected: LAKEWOOD, CO (Union & West 2nd <br> <a href="https://www.google.com/maps/place/264+Union+Blvd,+Lakewood,+CO+80228/@39.7197355,-105.1323572,221m/data=!3m1!1e3!4m5!3m4!1s0x876b8400b2b2f4a1:0x8465caa3994cc6bb!8m2!3d39.7197366!4d-105.1316974"> map</a>).