ASPNPK Branch Closure 3/15/2024
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 22:25 UTC
Investigating
The Aspen Park Branch will be closed 3/15/2024 due to today's snowstorm.
Posted Mar 14, 2024 - 15:51 UTC
This incident affected: CONIFER, CO (Aspen Park Branch <br> <a href=" https://www.google.com/maps/place/25617+Conifer+Rd,+Conifer,+CO+80433/@39.5434488,-105.2932575,17z/data=!3m1!4b1!4m5!3m4!1s0x876b76b636ff1b8d:0xa8847f3becb9de30!8m2!3d39.5434488!4d-105.2910688"> map</a>).