SPRUCE Branch: Lobby closed, appointments available
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 15:37 UTC
Update
We are continuing to investigate this issue.
Posted Nov 04, 2020 - 00:55 UTC
Investigating
The SPRUCE branch lobby will be closed 11/4-11/7, appointments can be made by calling 303-440-6500.

Please note, appointments will not be available on Saturday 11/7.
Posted Nov 04, 2020 - 00:54 UTC
This incident affected: BOULDER, CO (Foothills Pkwy & Baseline Rd <br> <a href=" https://www.google.com/maps/place/4770+Baseline+Rd+%23100,+Boulder,+CO+80303/@39.9995882,-105.2365305,17z/data=!3m1!4b1!4m5!3m4!1s0x876bed9100596d85:0x68f24fb73917b95c!8m2!3d39.9995882!4d-105.2343418"> map</a>).