64andward
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 16:12 UTC
Investigating
We are currently investigating this issue.
Posted Mar 12, 2020 - 16:11 UTC
This incident affected: ARVADA, CO (64th & Sheridan Branch <br> <a href="https://www.google.com/maps/place/6350+Sheridan+Boulevard,+Arvada,+CO+80003/@39.8110762,-105.0537292,17z/data=!3m1!4b1!4m5!3m4!1s0x876b880a73e7307b:0xe5d7400cad7bbbb9!8m2!3d39.8110721!4d-105.0515405"> map</a>).