FRISCO Branch- Lobby Closed/Drive Up Only
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Apr 19, 2022 - 18:47 UTC
Update
We are continuing to investigate this issue.
Posted Apr 19, 2022 - 18:47 UTC
Investigating
Due to staffing shortages, the FRISCO branch will operate as Drive Up Only starting this morning through April 4th.
Posted Mar 14, 2022 - 14:52 UTC
This incident affected: FRISCO, CO (Frisco Branch<br> <a href="https://www.google.com/maps/search/960+N.+Ten+Mile+Dr,+P.O.+Box+5750,+Frisco,+CO+80443/@39.5897656,-106.096565,885m/data=!3m2!1e3!4b1"> map</a>).