FEDL Branch Power Outage
Incident Report for FBBranchStatus
Resolved
Power has been restored and the FEDL branch is now open.
Posted Oct 12, 2020 - 18:39 UTC
Investigating
The FEDL branch is currently experiencing a power outage. The ATM is unavailable due to the power outage.

No ETA has been provided by Xcel at this time. The branch will reopen once power is restored.
Posted Oct 12, 2020 - 12:53 UTC