TOWER Branch Closed
Incident Report for FBBranchStatus
Resolved
The TOWER Branch will resume normal operations today 12/18/2023.
Posted Dec 18, 2023 - 15:41 UTC
Investigating
The TOWER Branch will be closed on 12/16/2023, the branch is expected to resume normal operations on 12/18/2023.
Posted Dec 16, 2023 - 16:00 UTC
This incident affected: AURORA, CO (Hampden & Tower Branch <br> <a href=" https://www.google.com/maps/place/18600+E+Hampden+Ave,+Aurora,+CO+80013/@39.6526485,-104.7728333,17z/data=!3m1!4b1!4m5!3m4!1s0x876c899976b7a2b9:0xea48c1f8584dd00f!8m2!3d39.6526485!4d-104.7706446"> map</a>).