DOUG Drive Up Closed
Incident Report for FBBranchStatus
Resolved
The DOUG Drive Up is open.
Posted Jul 18, 2022 - 19:39 UTC
Update
The Drive Up at the DOUG Branch will be closed until June 21st.
Posted May 26, 2022 - 16:29 UTC
Investigating
Due to staffing constraints, the Drive Up at the DOUG Branch will be closed until June 6th.
Posted May 10, 2022 - 17:00 UTC
This incident affected: CASTLE ROCK, CO (Plum Creek Branch <br> <a href="https://www.google.com/maps/place/2+Plum+Creek+Pkwy,+Castle+Rock,+CO+80104/@39.3653054,-104.8647384,17z/data=!3"> map</a>).