CARBON Branch Closed
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Nov 06, 2020 - 15:17 UTC
Investigating
Due to the current public health crisis the CARBON branch will be closed for the remainder of the day. The branch will reopen tomorrow.
Posted Nov 05, 2020 - 22:47 UTC