MONUMT Branch Closure 3/14/2024
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 15:12 UTC
Investigating
The Monument Branch will be closed 3/14/2024 due to today's snowstorm.
Posted Mar 14, 2024 - 15:50 UTC
This incident affected: COLORADO SPRINGS, CO (Powers Branch <br> <a href=" https://www.google.com/maps/place/5815+Constitution+Ave,+Colorado+Springs,+CO+80915/@38.8714795,-104.7215008,17z/data=!3m1!4b1!4m5!3m4!1s0x871346250842c2c9:0xad13bc499ed2309f!8m2!3d38.8714795!4d-104.7193121"> map</a>).