AURO Evacuated Due to Smell of Gas
Incident Report for FBBranchStatus
Resolved
Normal operations have resumed.
Posted Jun 09, 2023 - 17:02 UTC
Investigating
The AURO branch has been evacuated due to the smell of gas.
Posted Jun 09, 2023 - 16:29 UTC
This incident affected: AURORA, CO (Havana and Iliff Branch <br> <a href="https://www.google.com/maps/place/2300+S+Havana+St,+Aurora,+CO+80014/@39.6744545,-104.8676485,17z/data=!3m1!4b1!4m5!3m4!1s0x876c7d5f73c64b3f:0xca07fb1e3316e925!8m2!3d39.6744545!4d-104.8654598"> map</a>).