FEDL Branch - Lobby Closed, Drive up Only
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 14:02 UTC
Update
We are continuing to investigate this issue.
Posted Apr 01, 2021 - 22:38 UTC
Investigating
The FEDL Branch will run as drive up only for the remainder of the business day.
Posted Apr 01, 2021 - 22:37 UTC
This incident affected: DENVER, CO (Federal Branch <br> <a href=" https://www.google.com/maps/place/275+S+Federal+Blvd,+Denver,+CO+80219/@39.7117408,-105.0277213,17z/data=!3m1!4b1!4m5!3m4!1s0x876c7f67477a4353:0x94cd334409c2633d!8m2!3d39.7117408!4d-105.0255326"> map</a>).