CANDEL Branch - Lobby Closed/ Drive Up Open
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 16:14 UTC
Investigating
We are currently investigating this issue.
Posted Apr 05, 2021 - 21:38 UTC
This incident affected: ARVADA, CO (Candelas Pkwy & Indiana <br> <a href=" https://www.google.com/maps/place/14827+Candelas+Pkwy,+Arvada,+CO+80007/@39.8598957,-105.1703278,17z/data=!3m1!4b1!4m5!3m4!1s0x876b8e8be0cdf709:0xb79f2bdf930fcd4c!8m2!3d39.8598957!4d-105.1681391"> map</a>).