Colorado FirstBank Branches Delayed Opening 3/15
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Mar 15, 2021 - 18:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2021 - 17:26 UTC
Investigating
Most Colorado branch locations will operate on a delayed start, Monday, 3/15/21. Branches will open at 10am due to the inclement weather.
Posted Mar 15, 2021 - 01:48 UTC
This incident affected: LOUISVILLE, CO (Louisville Branch <br> <a href="https://www.google.com/maps/place/500+McCaslin+Blvd,+Louisville,+CO+80027/@39.9636992,-105.1650459,881m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876bf32e4c707ccb:0x56b104f28658222d!8m2!3d39.9636951!4d-105.1628572"> map</a>), GREELEY, CO (Hwy 34 & 23rd <br> <a href="https://www.google.com/maps/place/2901+23rd+Ave,+Greeley,+CO+80631/@40.3904314,-104.7184152,875m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876ea10e08482767:0xab85e62ab3589bc6!8m2!3d40.3904273!4d-104.7162265"> map</a>, 47th & 10th <br> <a href="https://www.google.com/maps/place/4322+9th+St+Rd,+Greeley,+CO+80634/@40.4222181,-104.7529437,875m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876ea3f7c02418a3:0x8cfa4443571e8a74!8m2!3d40.422214!4d-104.750755"> map</a>), LOVELAND, CO (Eisenhower & Taft <br> <a href="https://www.google.com/maps/place/1352+W+Eisenhower+Blvd,+Loveland,+CO+80537/@40.4069718,-105.0987127,875m/data=!3m2!1e3!4b1!4m5!3m4!1s0x8769524c9e8c0239:0xbad230d34b4768bc!8m2!3d40.4069677!4d-105.096524"> map</a>), CENTENNIAL, CO (Arapahoe & Yosemite Branch <br> <a href=" https://www.google.com/maps/place/8600+E+Arapahoe+Rd,+Centennial,+CO+80112/@39.5943908,-104.8905693,17z/data=!3m1!4b1!4m5!3m4!1s0x876c867e9c9384cf:0xb641fd6e1ed44335!8m2!3d39.5943908!4d-104.8883806"> map</a>, Holly Branch <br> <a href=" https://www.google.com/maps/place/8280+S+Holly+St,+Centennial,+CO+80122/@39.5664969,-104.9245111,17z/data=!3m1!4b1!4m5!3m4!1s0x876c8413693b0be3:0xe0ae1da0fa7ee231!8m2!3d39.5664969!4d-104.9223224"> map</a>, Smoky Hill & Himalaya Branch <br> <a href=" https://www.google.com/maps/place/19771+E+Smoky+Hill+Rd,+Centennial,+CO+80015/@39.6136115,-104.7597063,17z/data=!3m1!4b1!4m5!3m4!1s0x876c8956d1e459b9:0x38b22293a991058e!8m2!3d39.6136115!4d-104.7575176"> map</a>, Southglenn Branch <br> <a href=" https://www.google.com/maps/place/2323+E+Arapahoe+Rd,+Centennial,+CO+80121/@39.5955775,-104.9629325,17z/data=!3m1!4b1!4m5!3m4!1s0x876c81418b672e71:0x7b373015936478a7!8m2!3d39.5955775!4d-104.9607438"> map</a>), WINDSOR, CO (15th & Main <br> <a href="https://www.google.com/maps/place/1510+Main+St,+Windsor,+CO+80550/@40.4798962,-104.9294387,874m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876eb1f02a611c97:0xcff2036a14977e0b!8m2!3d40.4798962!4d-104.92725"> map</a>), COLORADO SPRINGS, CO (Briargate & Union Branch <br> <a href=" https://www.google.com/maps/place/2790+Briargate+Blvd,+Colorado+Springs,+CO+80920/@38.9421344,-104.7779385,17z/data=!3m1!4b1!4m5!3m4!1s0x87134e97deb4f607:0xd0f61c1665e0dd!8m2!3d38.9421344!4d-104.7757498"> map</a>, Cascade Branch <br> <a href=" https://www.google.com/maps/place/2+N+Cascade+Ave+%23130,+Colorado+Springs,+CO+80903/@38.834265,-104.8277877,17z/data=!3m1!4b1!4m5!3m4!1s0x871345233e092739:0x9f737418fa00f3d1!8m2!3d38.834265!4d-104.825599"> map</a>, Chey Mtn Branch <br> <a href=" https://www.google.com/maps/place/405+E+Cheyenne+Mountain+Blvd,+Colorado+Springs,+CO+80906/@38.7889077,-104.8237706,17z/data=!3m1!4b1!4m5!3m4!1s0x8713449f524d3f41:0x2eec23397790535a!8m2!3d38.7889077!4d-104.8215819"> map</a>, Garden Branch <br> <a href=" https://www.google.com/maps/place/1275+Garden+of+the+Gods+Rd,+Colorado+Springs,+CO+80907/@38.8961586,-104.8526071,17z/data=!3m1!4b1!4m5!3m4!1s0x8713502925ba22ad:0xf3e4caa04b54eb26!8m2!3d38.8961586!4d-104.8504184"> map</a>, Monument Branch <br> <a href=" https://www.google.com/maps/place/1010+Baptist+Rd,+Monument,+CO+80132/@39.0570022,-104.8441392,17z/data=!3m1!4b1!4m5!3m4!1s0x876cb29cdaf4f883:0xfeee7b6eb66016e3!8m2!3d39.0569981!4d-104.8419505 "> map</a>, Powers Branch <br> <a href=" https://www.google.com/maps/place/5815+Constitution+Ave,+Colorado+Springs,+CO+80915/@38.8714795,-104.7215008,17z/data=!3m1!4b1!4m5!3m4!1s0x871346250842c2c9:0xad13bc499ed2309f!8m2!3d38.8714795!4d-104.7193121"> map</a>), WESTMINSTER, CO (88th & Wadsworth<br> <a href="https://www.google.com/maps/place/8800+Wadsworth+Blvd,+Westminster,+CO+80021/@39.8575435,-105.0830979,882m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b89086dd5d7d5:0x906187426e3a7a1c!8m2!3d39.8575394!4d-105.0809039"> map</a>, 104th & Federal <br> <a href="https://www.google.com/maps/place/10367+Federal+Blvd,+Westminster,+CO+80260/@39.8839483,-105.027846,882m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c761b4dbc3eaf:0x31667f29af93f893!8m2!3d39.8839442!4d-105.025652"> map</a>, 120th & Sheridan <br> <a href="https://www.google.com/maps/place/5130+W+120th+Ave,+Westminster,+CO+80020/@39.9135452,-105.0521591,881m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b8a6b7fe90a23:0x80c1caaa0f81b428!8m2!3d39.9135411!4d-105.0499651"> map</a>), COMMERCE CITY, CO (104th & Chambers Branch <br> <a href=" https://www.google.com/maps/place/15250+E+104th+Ave,+Commerce+City,+CO+80022/@39.8850296,-104.8121296,17z/data=!3m1!4b1!4m5!3m4!1s0x876c6e527c7af93f:0xab377c060436be8d!8m2!3d39.8850296!4d-104.8099409"> map</a>), CONIFER, CO (Aspen Park Branch <br> <a href=" https://www.google.com/maps/place/25617+Conifer+Rd,+Conifer,+CO+80433/@39.5434488,-105.2932575,17z/data=!3m1!4b1!4m5!3m4!1s0x876b76b636ff1b8d:0xa8847f3becb9de30!8m2!3d39.5434488!4d-105.2910688"> map</a>), THORNTON, CO (136th & Colorado Blvd. <br> <a href="https://www.google.com/maps/place/13600+Colorado+Blvd,+Thornton,+CO+80602/@39.9434168,-104.9418498,881m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c747f9cd1e0fd:0x439ce7c40cf9d758!8m2!3d39.9434127!4d-104.9396611"> map</a>, 104th & Colorado Blvd. <br> <a href="https://www.google.com/maps/place/FirstBank/@39.8841361,-104.9496718,3416m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c76ca93b59b91:0x6b4d9836626d69ad!8m2!3d39.88412!4d-104.940917"> map</a>), DENVER, CO (6th & Speer Branch <br> <a href=" https://www.google.com/maps/place/600+Broadway,+Denver,+CO+80203/@39.7258612,-104.9893126,17z/data=!3m1!4b1!4m5!3m4!1s0x876c7f27a1f78521:0x830ab6961d664783!8m2!3d39.7258612!4d-104.9871239"> map</a>, 29th & Quebec Branch <br> <a href=" https://www.google.com/maps/place/2850+Quebec+St,+Denver,+CO+80238/@39.757272,-104.9048021,17z/data=!3m1!4b1!4m5!3m4!1s0x876c7b8573b83c1b:0xbe30d60698c09a2f!8m2!3d39.757272!4d-104.9026134"> map</a>, 38th & Federal Branch <br> <a href=" https://www.google.com/maps/place/3801+Federal+Blvd,+Denver,+CO+80211/@39.7695926,-105.0279321,17z/data=!3m1!4b1!4m5!3m4!1s0x876c7886b807eadb:0x567a344ba09730ba!8m2!3d39.7695926!4d-105.0257434"> map</a>, Cherry Creek Branch <br> <a href=" https://www.google.com/maps/place/100+St+Paul+St+%23100,+Denver,+CO+80206/@39.7183236,-104.9528471,17z/data=!3m1!4b1!4m5!3m4!1s0x876c7e9757a45361:0x2a89b68ac3e2b6dd!8m2!3d39.7183236!4d-104.9506584"> map</a>, Colfax & Franklin Branch <br> <a href=" https://www.google.com/maps/place/1617+E+Colfax+Ave,+Denver,+CO+80218/@39.7401962,-104.9703029,17z/data=!3m1!4b1!4m5!3m4!1s0x876c7ecb5627732b:0x612405e4dde40947!8m2!3d39.7401962!4d-104.9681142"> map</a>, Federal Branch <br> <a href=" https://www.google.com/maps/place/275+S+Federal+Blvd,+Denver,+CO+80219/@39.7117408,-105.0277213,17z/data=!3m1!4b1!4m5!3m4!1s0x876c7f67477a4353:0x94cd334409c2633d!8m2!3d39.7117408!4d-105.0255326"> map</a>, Green Valley Ranch Branch <br> <a href=" https://www.google.com/maps/place/18521+Green+Valley+Ranch+Blvd,+Denver,+CO+80249/@39.7841315,-104.7735626,17z/data=!3m1!4b1!4m5!3m4!1s0x876c6415b48130d3:0xf94190cbd257e36f!8m2!3d39.7841315!4d-104.7713739"> map</a>, Hampden & Yosemite Branch <br> <a href=" https://www.google.com/maps/place/8901+E+Hampden+Ave,+Denver,+CO+80231/@39.6535143,-104.8866008,17z/data=!3m1!4b1!4m5!3m4!1s0x876c87991c44b097:0x7a3b875bf2b8ac2d!8m2!3d39.6535143!4d-104.8844121"> map</a>, University Hills Branch <br> <a href="https://www.google.com/maps/place/2740+S+Colorado+Blvd,+Denver,+CO+80222/@39.6669188,-104.9423973,17z/data=!3m1! "> map</a>, Colorado Blvd. & Ohio <br> <a href="https://www.google.com/maps/place/830+S+Colorado+Blvd,+Glendale,+CO+80246/@39.701861,-104.9423061,884m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c7e7f99287d57:0xd48eff7fb2ac44de!8m2!3d39.7018569!4d-104.9401174"> map</a>), PARKER, CO (S. Parker Rd. & Main St. <br> <a href="https://www.google.com/maps/place/10961+S+Parker+Rd,+Parker,+CO+80134/@39.5173478,-104.7678421,886m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c91e4e3f7a86d:0x2c2cb90ff8530ad2!8m2!3d39.5173437!4d-104.7656534"> map</a>, Lincoln Ave. & Jordan Rd. <br> <a href="https://www.google.com/maps/place/16530+Keystone+Blvd,+Parker,+CO+80134/@39.5332706,-104.7961728,886m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c8e3231444615:0xa1237f098753fe14!8m2!3d39.5332665!4d-104.7939841"> map</a>), LONGMONT, CO (17th Ave. & N. Main St. <br> <a href="https://www.google.com/maps/place/1707+Main+St,+Longmont,+CO+80501/@40.1889292,-105.1051986,878m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876bf940a417180f:0x2d1b7544b2147067!8m2!3d40.1889251!4d-105.1030099"> map</a>, Ken Pratt Pkwy. & Hover St. <br> <a href="https://www.google.com/maps/place/1270+S+Hover+St,+Longmont,+CO+80501/@40.1430573,-105.1322192,878m/data=!3m1!1e3!4m5!3m4!1s0x876bfa21bccc00fb:0x371deb33ce29dac!8m2!3d40.1430532!4d-105.1300305"> map</a>), LONE TREE, CO (Lincoln Ave. & Yosemite St. <br> <a href="https://www.google.com/maps/place/9217+Lincoln+Ave,+Lone+Tree,+CO+80124/@39.5367287,-104.8862815,886m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c851baf51a6b3:0x8bb48ea59a39560c!8m2!3d39.5367246!4d-104.8840928"> map</a>), BOULDER, CO (28th & Pearl Branch<br> <a href=" https://www.google.com/maps/place/2835+Pearl+St+Suite+A,+Boulder,+CO+80301/@40.0231533,-105.2592481,17z/data=!3m1!4b1!4m5!3m4!1s0x876bedd7ceb55a01:0x7771c2c43ae8169a!8m2!3d40.0231533!4d-105.2570594"> map</a>, Foothills Pkwy & Baseline Rd <br> <a href=" https://www.google.com/maps/place/4770+Baseline+Rd+%23100,+Boulder,+CO+80303/@39.9995882,-105.2365305,17z/data=!3m1!4b1!4m5!3m4!1s0x876bed9100596d85:0x68f24fb73917b95c!8m2!3d39.9995882!4d-105.2343418"> map</a>), LITTLETON, CO (Broadway & County Line Rd. <br> <a href="https://www.google.com/maps/place/101+W+County+Line+Rd,+Littleton,+CO+80129/@39.5670059,-104.9894059,221m/data=!3m1!1e3!4m5!3m4!1s0x876c822d8590a305:0x7db3408cc04dd65!8m2!3d39.5666927!4d-104.9891779"> map</a>, Ken Caryl & Simms <br> <a href="https://www.google.com/maps/place/11767+W+Ken+Caryl+Ave,+Littleton,+CO+80127/@39.5811434,-105.1338861,885m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b7934276fba33:0x23231d40b66fa2a8!8m2!3d39.5811393!4d-105.1316974"> map</a>, Kipling & Belleview <br> <a href="https://www.google.com/maps/place/5125+S+Kipling+St,+Littleton,+CO+80127/@39.6237108,-105.1127811,885m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b7f46fcc883d3:0x2326a56bfbe5b887!8m2!3d39.6237067!4d-105.1105924"> map</a>, Wadsworth & Coal Mine <br> <a href="https://www.google.com/maps/place/6701+S+Wadsworth+Blvd,+Littleton,+CO+80128/@39.5948464,-105.0942366,885m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b7ee53cff8d1d:0x424d1bd5eca4b0a!8m2!3d39.5948423!4d-105.0920479"> map</a>), LAKEWOOD, CO (Alameda & Wadsworth <br> <a href="https://www.google.com/maps/place/550+S+Wadsworth+Blvd,+Lakewood,+CO+80226/@39.7064903,-105.0831155,884m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b81203b8d3a4b:0x41ef85e8b05b1e85!8m2!3d39.7064862!4d-105.0809268"> map</a>, Kipling & Jewell <br> <a href="https://www.google.com/maps/place/1940+S+Kipling+Pkwy,+Lakewood,+CO+80227/@39.6816642,-105.1216431,17z/data=!3m1!4b1!4m5!3m4!1s0x876b8178c83b0381:0x411cdce1e5549d03!8m2!3d39.6816601!4d-105.1194544"> map</a>, Colfax & Kipling <br> <a href=" https://www.google.com/maps/place/First+Bank,+10403+W+Colfax+Ave,+Lakewood,+CO+80215/@39.7408695,-105.117834,883m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b86a2987675bf:0xd54d369ae86dcc41!8m2!3d39.7408654!4d-105.11564 "> map</a>, Union & West 2nd <br> <a href="https://www.google.com/maps/place/264+Union+Blvd,+Lakewood,+CO+80228/@39.7197355,-105.1323572,221m/data=!3m1!1e3!4m5!3m4!1s0x876b8400b2b2f4a1:0x8465caa3994cc6bb!8m2!3d39.7197366!4d-105.1316974"> map</a>, Wadsworth & Colfax <br> <a href="https://www.google.com/maps/place/7590+W+Colfax+Ave,+Denver,+CO+80214/@39.7398244,-105.0828186,883m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b86d8c0699fc5:0x6cf76b2f52501827!8m2!3d39.7398203!4d-105.0806299"> map</a>, Wadsworth & Hampden Ave. <br> <a href="https://www.google.com/maps/place/3500+S+Wadsworth+Blvd,+Lakewood,+CO+80235/@39.6514979,-105.0828186,885m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b81d31559221d:0x32180df44ea15709!8m2!3d39.6514938!4d-105.0806299"> map</a>, Colfax Ave & Denver W Bld <br> <a href="https://www.google.com/maps/place/14185+W+Colfax+Dr,+Golden,+CO+80401/@39.7348737,-105.1611392,883m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b84683b009e55:0x3dcfbe06c11ed53b!8m2!3d39.7348696!4d-105.1589505"> map</a>), BRIGHTON, CO (50th Ave & Bridge Branch <br> <a href=" https://www.google.com/maps/place/36+N+50th+Ave,+Brighton,+CO+80601/@39.9873556,-104.7536902,17z/data=!3m1!4b1!4m5!3m4!1s0x876c6b61d052d63d:0x7e3c9955456281ce!8m2!3d39.9873556!4d-104.7515015"> map</a>, Bromley Lane & Sable Blvd <br> <a href=" https://www.google.com/maps/place/410+E+Bromley+Ln,+Brighton,+CO+80601/@39.9717256,-104.819607,17z/data=!3m1!4b1!4m5!3m4!1s0x876c6d0df5e8cc31:0x9bf4c0d471981cd8!8m2!3d39.9717256!4d-104.8174183"> map</a>), BROOMFIELD, CO (136th & Zuni Branch <br> <a href=" https://www.google.com/maps/place/2155+W+136th+Ave,+Broomfield,+CO+80023/@39.9436399,-105.0152405,17z/data=!3m1!4b1!4m5!3m4!1s0x876c75724b525f07:0x6133b65ef9dd25a6!8m2!3d39.9436399!4d-105.0130518"> map</a>), CASTLE ROCK, CO (Founders Pkwy & I-25 Branch<br> <a href=" https://www.google.com/maps/place/4775+Front+St,+Castle+Rock,+CO+80104/@39.4100013,-104.8672157,17z/data=!3m1!4b1!4m5!3m4!1s0x876c99c1da4d11b3:0xde05c25d32a93e05!8m2!3d39.4100013!4d-104.865027"> map</a>, Plum Creek Branch <br> <a href="https://www.google.com/maps/place/2+Plum+Creek+Pkwy,+Castle+Rock,+CO+80104/@39.3653054,-104.8647384,17z/data=!3"> map</a>), HIGHLANDS RANCH, CO (Univ&HighRanch <br> <a href="https://www.google.com/maps/place/9409+S+University+Blvd,+Highlands+Ranch,+CO+80129/@39.5449424,-104.9479644,886m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c8383c5c65487:0x4b1128b63786f9c2!8m2!3d39.5449383!4d-104.9457757"> map</a>), ENGLEWOOD, CO (E Jefferson Ave & S Logan St <br> <a href="https://www.google.com/maps/place/3594+S+Logan+St,+Englewood,+CO+80113/@39.651425,-104.9847535,885m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c8086e222fa8d:0x4c40bc1b487f2feb!8m2!3d39.6514209!4d-104.9825595"> map</a>), ERIE, CO (HWY 7 and Sheridan Branch <br> <a href="https://www.google.com/maps/place/1779+CO-7,+Erie,+CO+80516/@40.0008545,-105.0109493,880m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c0aeb4ba91883:0xe5cb7569491b9f79!8m2!3d40.0008504!4d-105.0087606"> map</a>), GREENWOOD VILLAGE, CO (BellevAve&DTCPkwy. <br> <a href="https://www.google.com/maps/place/5105+DTC+Pkwy+%23100,+Greenwood+Village,+CO+80111/@39.6233526,-104.9024755,885m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c86fb87bc759f:0x5c418d272ed5be3b!8m2!3d39.6233485!4d-104.9002868"> map</a>), EVERGREEN, CO (Stagecoach Blvd. & Hwy. 74 <br> <a href="https://www.google.com/maps/place/30770+Stagecoach+Blvd,+Evergreen,+CO+80439/@39.6516619,-105.3476444,885m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b9ef7b49b3aa3:0xae3d8757a5d7a34!8m2!3d39.6516578!4d-105.3454557"> map</a>), FIRESTONE, CO (Colorado Blvd. & Firestone <br> <a href="https://www.google.com/maps/place/6080+Firestone+Blvd,+Longmont,+CO+80504/@40.1600986,-104.943675,878m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876c060999329081:0x3935e9073e0d90f4!8m2!3d40.1600945!4d-104.9414863"> map</a>), ARVADA, CO (64th & Ward Branch <br> <a href="https://www.google.com/maps/place/6355+Ward+Rd,+Arvada,+CO+80004/@39.8117081,-105.1405562,17z/data=!3m1!4b1!4m5!3m4!1s0x876b8f459b44a03b:0x4143e8551b50744e!8m2!3d39.811704!4d-105.1383675"> map</a>, WOODS 64th & McIntyre <br> <a href=" https://www.google.com/maps/place/15250+W+64th+Ave,+Arvada,+CO+80007/@39.8121221,-105.1734537,17z/data=!3m1!4b1!4m5!3m4!1s0x876b8f757526376d:0x68de51e20b344c5d!8m2!3d39.812118!4d-105.171265 "> map</a>, Candelas Pkwy & Indiana <br> <a href=" https://www.google.com/maps/place/14827+Candelas+Pkwy,+Arvada,+CO+80007/@39.8598957,-105.1703278,17z/data=!3m1!4b1!4m5!3m4!1s0x876b8e8be0cdf709:0xb79f2bdf930fcd4c!8m2!3d39.8598957!4d-105.1681391"> map</a>), FORT COLLINS, CO (E Harmony & S Lemay <br> <a href="https://www.google.com/maps/place/1013+E+Harmony+Rd,+Fort+Collins,+CO+80525/@40.5230943,-105.0608636,873m/data=!3m2!1e3!4b1!4m5!3m4!1s0x87694c9919528857:0xc5304a1b5907dacc!8m2!3d40.5230902!4d-105.0586749"> map</a>, S. College & E. Mountain <br> <a href="https://www.google.com/maps/place/100+S+College+Ave,+Fort+Collins,+CO+80524/@40.5867382,-105.0788777,872m/data=!3m2!1e3!4b1!4m5!3m4!1s0x87694af52edbc055:0x8f38485e7a5b970f!8m2!3d40.5867341!4d-105.076689 "> map</a>, Timberline & Drake <br> <a href="https://www.google.com/maps/place/2644+S+Timberline+Rd,+Fort+Collins,+CO+80525/@40.550563,-105.040716,873m/data=!3m2!1e3!4b1!4m5!3m4!1s0x87694b498607c02b:0xed2210e7899d9a2d!8m2!3d40.5505589!4d-105.0385273"> map</a>), WHEAT RIDGE, CO (44th Ave. & Wadsworth <br> <a href="https://www.google.com/maps/place/4350+Wadsworth+Blvd,+Wheat+Ridge,+CO+80033/@39.7760432,-105.0829561,883m/data=!3m2!1e3!4b1!4m5!3m4!1s0x876b86529969fb63:0xf7b3377f96b56325!8m2!3d39.7760391!4d-105.0807621"> map</a>), and AURORA, CO (Fitzsimons Branch <br> <a href="https://www.google.com/maps/place/13300+E+Colfax+Ave,+Aurora,+CO+80011/@39.7397567,-104.836843,17z/data=!3m1!4b1!4m5!3m4!1s0x876c63486fbeb375:0x4b2df6ec5ba45163!8m2!3d39.7397526!4d-104.8346543"> map</a>, Hampden & Tower Branch <br> <a href=" https://www.google.com/maps/place/18600+E+Hampden+Ave,+Aurora,+CO+80013/@39.6526485,-104.7728333,17z/data=!3m1!4b1!4m5!3m4!1s0x876c899976b7a2b9:0xea48c1f8584dd00f!8m2!3d39.6526485!4d-104.7706446"> map</a>, Havana and Iliff Branch <br> <a href="https://www.google.com/maps/place/2300+S+Havana+St,+Aurora,+CO+80014/@39.6744545,-104.8676485,17z/data=!3m1!4b1!4m5!3m4!1s0x876c7d5f73c64b3f:0xca07fb1e3316e925!8m2!3d39.6744545!4d-104.8654598"> map</a>, Smoky Hill & Arapahoe Rd Branch <br> <a href=" https://www.google.com/maps/place/25541+E+Smoky+Hill+Rd,+Aurora,+CO+80016/@39.5885405,-104.6919926,17z/data=!3m1!4b1!4m5!3m4!1s0x876c8ceeec06a2d3:0x8dee9cc94a4e02d9!8m2!3d39.5885405!4d-104.6898039"> map</a>).