Cleanup
Incident Report for FBBranchStatus
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 16:14 UTC
Investigating
We are currently investigating this issue.
Posted Mar 12, 2020 - 16:14 UTC
This incident affected: ARVADA, CO (64th & Ward Branch <br> <a href="https://www.google.com/maps/place/6355+Ward+Rd,+Arvada,+CO+80004/@39.8117081,-105.1405562,17z/data=!3m1!4b1!4m5!3m4!1s0x876b8f459b44a03b:0x4143e8551b50744e!8m2!3d39.811704!4d-105.1383675"> map</a>).